FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

VS.NET 2005 addin

I've installed the API and the VS.NET 2005 add-in, but it doesn't actually list any cases. I'm assuming that the URL and login details are all correct because it is able to correctly pull down the list of filters that should apply. I can use one of those filters via a web browser on the same machine and I get the cases I'd expect, but the VS.NET add-in shows nothing.

Any suggestions?
Andrew Lighten Send private email
Monday, December 18, 2006
 
 
Oh -- should have said -- FogBugz 5.0.19 running on Win2K3 server.
Andrew Lighten Send private email
Monday, December 18, 2006
 
 
Same problem here.
Michael Dorfman
Tuesday, December 19, 2006
 
 
Same here.

A quick look with Fiddler suggests that it never actually asks for any cases, either.  Does a login, gets a token, then nothing.
Will Dean
Tuesday, December 19, 2006
 
 
Even better - the addin's now decided to sulk altogether - every menu options is grayed-out.  Possibly a result of rebooting my FB server, but anyway...

FCS had probably better hold back a bit before they attempt to charge for this one...
Will Dean
Tuesday, December 19, 2006
 
 
Try to set client/department permissions to 'All users can ...' for some project which cases aren't shown

In my case, this solves the problem.

However, I suppose that this Add-In behavior is quite strange :)
Maxim V. Chuvilyaev Send private email
Tuesday, December 19, 2006
 
 
I don't think I'm going to publish all my clients' bugs to each other, just to get this add-in working!

And another thing.... 

When I set the add-in as page on one of the multi-paged VS windows, it doesn't appear when I start the IDE.  I have to go to View->Other Windows and turn it on again.

0 out of 10 for this one, I'm afraid.
Will Dean
Tuesday, December 19, 2006
 
 
Yeah, I get that startup behaviour too -- have to manually start it.
Andrew Lighten Send private email
Tuesday, December 19, 2006
 
 
Thanks for the bug reports, all.  I'm passing them on to Joel.
Sumana Harihareswara Send private email
Tuesday, December 19, 2006
 
 
Hi!

We think we've found the problem most people here are reporting... Michael Pryor got it fixed for Andrew, so we should be rolling out a new version of the API in the next day (at the latest), murphy-willing.

I think that problem happened because the FogBugz API wasn't recognizing admins and giving them magical admin-juice.

As for the window not reappearing when you restart the IDE, I hope to have a fix for that soon, too. I believe that the problem only happens when you have the wee FogBugz window set to autohide.

Thanks for all your patience, and if there are other bugs don't hesitate to email customer-service@fogcreek.com; I'm working through them all right now.
Joel Spolsky Send private email
Tuesday, December 19, 2006
 
 
A new version of the API is now up on

http://www.fogcreek.com/FogBugz/KB/setup/InstallFogBugzAPI.html

which fixes the problem with no cases showing up.
Joel Spolsky Send private email
Tuesday, December 19, 2006
 
 
Yup. Seems to work a lot better.

Thanks for that.
Will Dean
Tuesday, December 19, 2006
 
 
I am finding that the add-in occasionally hangs the whole VS 2005 environment with 100% CPU usage when I switch filters.  Other times it fails to read any cases at all, showing just a disabled menu bar and the word Loading...

I'll try to pinpoint the problem and provide more info if you like.

Running on XP, 5.0.19 server with the updated API files, VS 2005 (pre-SP1).
Chris F Send private email
Wednesday, December 20, 2006
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.