FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

Upgrading from 2.0 to 4.0

Hello,

We have an old 2.0 installation, and have decided to upgrade to 4.0.

Is it possible to import/merge 2.0 data into 4.0 ??
Jan Ahlbeck Send private email
Wednesday, March 9, 2005
 
 
The 4.0 installer should upgrade 2.0.  You can run it on a backup of your database to be sure, and if you have any problems, you can run the 3.0 install first (2.0->3.0->4.0)

Hope that helps!
Michael H. Pryor Send private email
Wednesday, March 9, 2005
 
 
Thanks,

We do not have the 3.0, but plans to jump direct to 4.0.

Is the 3.0 installer included in 4.0 ???
Jan Ahlbeck Send private email
Friday, March 11, 2005
 
 
The 4.0 installer should do the upgrade fine... you can jump from 2.0 to 4.0.  if it doesn't, let us know.
Michael H. Pryor Send private email
Friday, March 11, 2005
 
 
NEW PROBLEM, HELP

Got the problem you describen in:

http://www.fogcreek.com/FogBugz/KB/trouble/BugEventPrimaryKey.html

fixed it and the installer went further, but then got error in databse upgrade:

'Item cannot be found in the collection corresponding to the requested name or ordinal'

What to do ??

-- What have i done to get this problem.

1. Exported out FB 2.0.3 batabasen running on sql 7.0 to a new server running win2k and sql 2000

2. Installed fb 2.0.3, worked fine

3. Started to upgrade to 4.0.11, and got the message i have mentioned.

4. The installation 'rollback'

now what ??
Jan Ahlbeck Send private email
Tuesday, March 15, 2005
 
 
I have logged the 2.0 to 4.0 upgrade bug, and we will work on  repro and fix here. In the meantime, the fastest way to get you up and running with 4.0 will be to do an upgrade to FB3, and then an upgrade from there to FB4. I will contact you via email and make sure you get a copy of the FB3 installer.
Brett Kiefer Send private email
Tuesday, March 15, 2005
 
 
I got this error on a new install of FB 4.x
david Send private email
Thursday, March 31, 2005
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.