FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

Email woes continued

Following up from a previous discussion, I'm still having problems getting email notifications to work properly from FB4. (http://support.fogcreek.com/default.asp?fogbugz.4.2548.10)

It seems that the Dispatcho service runs but doesn't do anything. If I manually open heartbeat.asp and continually refresh it until I get a '-' everything works. But the service doesn't deliver the mail itself.

So now I'm going to write a simple batch file to get heartbeat.asp until I get a '-' back and then run it every minute as a workaround.

Is there anything else that Dispatcho does that I should be aware of? Do you guys have a fix for this? People are starting to get annoyed here that the email never works after we upgraded...
David Avraamides Send private email
Monday, March 28, 2005
 
 
Hi David-
Yes, the "Fog Creek Dispatcho" service does nothing now, and installation should have set up another service called "FogBugz Maintenance Service," which does more or less what you have described your batch job doing: it hits heartbeat until it gets a "-". Is "FogBugz Maintenance Service" running?

From the fact that you knew to hit Heartbeat.asp, it sounds like you've already read this knowledge base article, but just to be sure: http://fogcreek.com/windows/trouble/NotificationProblems.html
Brett Kiefer Send private email
Monday, March 28, 2005
 
 
In case anyone else is having the problem, here is the script I'm running every two minutes to force mail to go through...
--
on error resume next

set http = CreateObject("MSXML2.ServerXMLHTTP")

done = false
url = "http://bugs/heartbeat.asp"
do while not done
    http.open "GET", url, false
    http.send ""
    if http.Status <> "200" or http.ResponseText = "-" then
        done = true
    end if
loop

set http = nothing

--
David Avraamides Send private email
Monday, March 28, 2005
 
 
There is no "Fog Bugz Maintenance Service" in my services list.
David Avraamides Send private email
Monday, March 28, 2005
 
 
Hi David-

This is a result of your early setup woes, when you turned up the case-sensitive DB bug. As I remember, you and I walked through getting you set up manually. I must have missed the fact that your maintenance service was never installed. What we should have done was walk through these instructions:

http://www.fogcreek.com/FogBugz/docs/40/Articles/Installing/WindowsWhatSetupDoes.html

The thing to do now is to install the maintenance service manually, following the instructions at the bottom of that document. Then you should probably skim the document to make sure we didn't miss anything else. If you have any questions, please call our customer service line for immediate assistance.
Brett Kiefer Send private email
Monday, March 28, 2005
 
 
OK, I installed the maintenance service, disabled my script and mail seems to be flowing through now.

Can I remove the old Dispatcho service so I don't get confused again?
David Avraamides Send private email
Monday, March 28, 2005
 
 
Yes, you certainly can remove the old Dispatcho service -- it won't hurt anything, but like you say, it's confusing.
Brett Kiefer Send private email
Monday, March 28, 2005
 
 
Hi I am also getting this problem.

I can manually refresh heartbeat.asp and the mails are sent, so SMTP etc must be ok on the server.

The service Fogbugz Maintenance Service is running with no errors, but no emails are being sent automatically.

The website is running on Win 2003 web server, the database is SQL Server all other aspects of Fogbugz appear ok.

Any help would be much appreciated!
Sinéad Magennis
Friday, April 22, 2005
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.